Redisinsight fails to launch in osx 10.13

As a Mac user, looking at the documentation I still read that the minimum requirement is to have OSX 10.13.

After the last update of the application I learn from reading the logs, despite myself, that now the minimum requirement is OSX 10.14. The Mac I use is not compatible with this version of the operating system.

The crazy thing is that the application constantly showed me to run the update, without notifying me that after that I would no longer be able to use it, due to compatibility problems with my operating system.

Hello @Luca, I’m Nishant from the RedisInsight team.

This breakage is unintentional, i.e, it is not intended to drop support for OSX 10.13.

The last version of RedisInsight (1.8.3) fixed support for OSX 11.1, but it seems to have broken something for OSX 10.13.

We are in the process of fixing this and updating our test infrastructure to ensure future releases work for all versions of OSX from 10.13 and up.

In the meantime, you can either remove the ~/.redisinsight directory and use RedisInsight 1.8.2 instead, or use the Docker image of RedisInsight.
In both cases, you’ll be starting a fresh RedisInsight and you’ll have to add your Redis databases again.

Sorry for this bug, we’re on it and I’ll post an update here when it’s fixed :slight_smile:

1 Like

I understand, and I thank you for offering me the possibility to download the previous version that I, very lightly, had deleted without protecting myself on the compatibility of the last one.

1 Like